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Google Analytics 4: Troubleshooting
Alina Marques avatar
Written by Alina Marques
Updated over a year ago

A few scenarios can result in issues with your Google Analytics 4 Plugin. Below you can find a list of common issues alongside the common causes and resolutions.

Google Analytics Account Disconnected

If the Google Analytics Account connected with Visual UGC is no longer working, you will be notified on a banner that the account needs to be reconnected.

The good news is that since Visual UGC only uses the Google Account to read data from your account, Visual UGC will keep tracking data even if the account is temporarily disconnected.

Common Causes:

The common causes for this type of error are:

  • The Google Analytics account has been disabled.

  • The Google Analytics account changed the password or enabled 2MF after the connection.

  • The permissions of the Google Analytics account were changed to Viewer.

Resolution:

To solve this error, just click Reconnect Now on the Error banner or Google Analytics 4 Plugin Config page

Google Analytics Account does not have the required permissions

Visual UGC relies on a list of custom dimensions and Measurement Protocol API secrets that need to be created in your account at the time of enabling tracking. If the connected Google account doesn't have the required permissions in Google Analytics, you will not be able to start the tracking.

Common Causes:

The common causes for this type of error are:

  • The Google account connected does not have access to Google Analytics.

  • The Google account connected has a Viewer role

Resolution:

To solve this error, you need to ensure the connected account has an Analyst role or higher permissions role. As an alternative, consider connecting a different Google account with the required permissions.

To reconnect, please restart the config and click the Disconnect button in the bottom right corner.

Error loading the data in your Dashboards

On some occasions, Visual UGC might have issues loading the data into your reports.

Common Causes:

The common causes for this type of error are:

  1. The custom dimensions that Visual UGC relies on were manually removed from your Google Analytics account.

  2. The Measurement Protocol API secret that Visual UGC relies on for Email tracking was manually removed from your Google Analytics account.

  3. You have exceeded your Google API rate limit

Resolution:

  • Scenario 1: Please refer to these steps

  • Scenario 2: Please follow the steps here to locate the custom dimensions in your account and ensure all the dimensions on the list are there. If not, please return to the Google Analytics 4 Plugin Config page and click Save Changes again. That should prompt the creation of the dimensions again.

  • Scenario 3: Please follow the steps here to locate the Measurement Protocol API secret for Nosto UGC in your account and ensure it's there. If not, please return to the Google Analytics 4 Plugin Config page and click Save Changes again. That should prompt the creation of the secret again.

  • Scenario 4: Please wait a few minutes a try again. If the problem persists over time, please raise an email to support@nosto.com, and our support team will get back to you.

Event Tracking Error

On limited occasions, Visual UGC might face issues tracking your events that are not from any of the previous scenarios.

Common Causes:

The common causes for this type of error are:

  • The Account, Property, or Data Stream configured for the Plugin are no longer valid

Resolution:

Please ensure that the configuration you have is still valid. If you believe the configuration is correct, please raise an email to support@nosto.com with the Error code displayed in the banner, and our support team will get back to you.

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